<!DOCTYPE html>
<html lang="en-US" xmlns:fb="http://ogp.me/ns/fb#" xmlns:addthis="http://www.addthis.com/help/api-spec" >
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.lafayettestudentnews.com/xmlrpc.php">

<title>Trump&#8217;s Incompetence Continues: Column &#8211; The Lafayette</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Lafayette &raquo; Trump&#8217;s Incompetence Continues: Column Comments Feed" href="https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.lafayettestudentnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.1"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dw-focus-main-css'  href='https://www.lafayettestudentnews.com/wp-content/themes/dw-focus/assets/css/dw-focus.min.css?ver=1.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-style-css'  href='https://www.lafayettestudentnews.com/wp-content/themes/dw-focus/style.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-print-css'  href='https://www.lafayettestudentnews.com/wp-content/themes/dw-focus/assets/css/print.css?ver=1.3.2' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.4 - Universal disabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-43819023-1']);
	_gaq.push(['_gat._forceSSL']);
	_gaq.push(['_trackPageview']);

	(function () {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-content/themes/dw-focus/assets/js/modernizr.min.js?ver=1.3.2'></script>
<script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-content/themes/dw-focus/assets/js/jquery-mobile.min.js?ver=1.3.2'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.lafayettestudentnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.lafayettestudentnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='&#8216;Good as Gone&#8217; doesn&#8217;t live up to &#8216;Gone Girl&#8217;' href='https://www.lafayettestudentnews.com/blog/2017/02/17/good-as-gone-doesnt-live-up-to-gone-girl/' />
<link rel='next' title='Housing exemption to end: Three student limit to be enforced' href='https://www.lafayettestudentnews.com/blog/2017/02/17/housing-exemption-to-end-three-student-limit-to-be-enforced/' />

<link rel="canonical" href="https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/" />
<link rel='shortlink' href='https://www.lafayettestudentnews.com/?p=18159' />
<link rel="alternate" type="application/json+oembed" href="https://www.lafayettestudentnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lafayettestudentnews.com%2Fblog%2F2017%2F02%2F17%2Ftrumps-incompetence-continues%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.lafayettestudentnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lafayettestudentnews.com%2Fblog%2F2017%2F02%2F17%2Ftrumps-incompetence-continues%2F&#038;format=xml" />
<link rel="alternate" type="application/rss+xml" title="The Lafayette &raquo; Feed" href="https://www.lafayettestudentnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Lafayette &raquo; Comments Feed" href="https://www.lafayettestudentnews.com/comments/feed/" />
<meta name="google-site-verification" content="eK8HfOPPiYuqJc2NPTS8vd_4NE3b_dYYIuICe8HPNc8" /><style type="text/css">a {color: #ee3224}a:hover, a:active {color: #000000}.site-footer {color: #555555}.site-footer a {color: #777777}.site-footer a:hover, .site-footer a:active {color: #ffffff}.site-footer #footer-widgets .widget-title {color: #cd3131}.site-footer .footer-navigation, #footer-widgets { border-color: #cd3131}#footer-widgets .widget_nav_menu:after {background-color: #cd3131}.site-footer {background-color:#000000}body {color:#333333;font-weight:500;font-weight:500;font-size:16px;font-family:Times New Roman;line-height:1.5;}h1, h2, h3, h4, h5, h6, .dw_focus_widget_news_slider .carousel-title-indicators li, .widget_news-slider .carousel-title-indicators li, .post-navigation .nav-links, .dw_focus_widget_news_ticker a, .widget_news-ticker a {font-weight: 700;font-family:Roboto;line-height:1.3;}h1 {font-size:36px}h2 {font-size:30px}h2 {font-size:30px}h3 {font-size:24px}h4 {font-size:18px}h5 {font-size:14px}h6 {font-size:12px}</style><link rel="icon" href="https://www.lafayettestudentnews.com/wp-content/uploads/2013/08/Logo.png" sizes="32x32" />
<link rel="icon" href="https://www.lafayettestudentnews.com/wp-content/uploads/2013/08/Logo.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.lafayettestudentnews.com/wp-content/uploads/2013/08/Logo.png" />
<meta name="msapplication-TileImage" content="https://www.lafayettestudentnews.com/wp-content/uploads/2013/08/Logo.png" />
<meta data-pso-pv="1.2.1" data-pso-pt="singlePost" data-pso-th="6d5d57c258600aac25f28c65754c8eca"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script pagespeed_no_defer="" data-pso-version="20170207_220711">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</script></head>

<body class="single single-post postid-18159 single-format-standard layout-wide sidebar-right">
<div id="page" class="hfeed site">
	<header class="site-header">
		<div class="container">
			<div class="row hidden-xs hidden-sm">
				<div class="col-md-4">
																<a href="https://www.lafayettestudentnews.com/" rel="home" class="site-logo"><img src="//www.lafayettestudentnews.com/wp-content/uploads/2013/08/The-flag-for-website-e1471464996823.jpg" title="The Lafayette"></a>
									</div>
								<div id="header-widgets" class="col-md-8"><aside id="text-10" class="widget widget_text"><h2 class="widget-title">The Oldest College Newspaper in Pennsylvania, serving Lafayette College since 1870</h2>			<div class="textwidget"></div>
		</aside></div>
							</div>
						<div class="navigation-wrap under-navigation-activated">
								<nav id="masthead" class="navbar navbar-default site-navigation" role="banner">
					<div class="navbar-header">
												<button class="navbar-toggle" data-toggle="collapse" data-target=".main-navigation"><i class="fa fa-bars"></i></button>
												<a href="https://www.lafayettestudentnews.com/" rel="home" class="site-brand navbar-brand visible-xs visible-sm">
																						<img src="//www.lafayettestudentnews.com/wp-content/uploads/2013/08/The-flag-for-website-e1471464996823.jpg" title="The Lafayette">
													</a>
													<button class="search-toggle visible-xs visible-sm" data-toggle="collapse" data-target=".under-navigation"><i class="fa fa-search"></i></button>
											</div>

					<div id="site-navigation" class="collapse navbar-collapse main-navigation" role="navigation">
						<ul id="menu-menu" class="nav navbar-nav navbar-left"><li class="menu-home"><a href="http://www.lafayettestudentnews.com/">Home</a></li>
<li class="current-post-ancestor active current-post-parent dropdown menu-news"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="https://www.lafayettestudentnews.com/blog/category/news/">News <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="menu-students"><a href="https://www.lafayettestudentnews.com/blog/category/news/students/">Students</a></li>
	<li class="menu-money"><a href="https://www.lafayettestudentnews.com/blog/category/news/money/">Money</a></li>
	<li class="menu-the-college"><a href="https://www.lafayettestudentnews.com/blog/category/news/the-college/">The College</a></li>
	<li class="menu-expansion-plans"><a href="https://www.lafayettestudentnews.com/blog/category/news/expansion-plans/">Expansion plans</a></li>
	<li class="menu-events"><a href="https://www.lafayettestudentnews.com/blog/category/news/presentations/">Events</a></li>
	<li class="menu-faculty-and-staff"><a href="https://www.lafayettestudentnews.com/blog/category/news/faculty-and-staff/">Faculty and staff</a></li>
	<li class="menu-academics"><a href="https://www.lafayettestudentnews.com/blog/category/news/academics/">Academics</a></li>
	<li class="menu-student-government"><a href="https://www.lafayettestudentnews.com/blog/category/news/student-government/">Student Government</a></li>
	<li class="menu-greek-life"><a href="https://www.lafayettestudentnews.com/blog/category/news/greek-life/">Greek Life</a></li>
</ul>
</li>
<li class="dropdown menu-sports"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="https://www.lafayettestudentnews.com/blog/category/sports/">Sports <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="menu-mens-sports"><a href="https://www.lafayettestudentnews.com/blog/category/sports/mens-sports/">Men&#8217;s Sports</a></li>
	<li class="menu-womens-sports"><a href="https://www.lafayettestudentnews.com/blog/category/sports/womens-sports/">Women&#8217;s Sports</a></li>
	<li class="menu-coaches-corner"><a href="https://www.lafayettestudentnews.com/blog/category/sports/other/coaches-corner/">Coaches Corner</a></li>
	<li class="menu-side-lines"><a href="https://www.lafayettestudentnews.com/blog/category/op-ed/sports-opinion/side-lines/">Side Lines</a></li>
	<li class="menu-sports-recap-central"><a href="https://www.lafayettestudentnews.com/blog/category/sports/other/sportsrecapcentral/">Sports Recap Central</a></li>
	<li class="menu-timeout-with"><a href="https://www.lafayettestudentnews.com/blog/category/sports/other/timeout-with/">Timeout with&#8230;</a></li>
</ul>
</li>
<li class="dropdown menu-arts-and-culture"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="https://www.lafayettestudentnews.com/blog/category/arts/">Arts and Culture <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="menu-eclectic-excursions"><a href="https://www.lafayettestudentnews.com/blog/category/arts/eclectic-excursions/">Eclectic Excursions</a></li>
	<li class="menu-previews"><a href="https://www.lafayettestudentnews.com/blog/category/arts/previews/">Previews</a></li>
	<li class="menu-reviews"><a href="https://www.lafayettestudentnews.com/blog/category/arts/reviews/">Reviews</a></li>
	<li class="menu-lafayette-history"><a href="https://www.lafayettestudentnews.com/blog/category/arts/lafayette-history/">Lafayette History</a></li>
	<li class="menu-paper-playlist"><a href="https://www.lafayettestudentnews.com/blog/category/arts/paper-playlist/">Paper Playlist</a></li>
	<li class="menu-six-word-review"><a href="https://www.lafayettestudentnews.com/blog/category/arts/six-word-review/">Six-Word Review</a></li>
</ul>
</li>
<li class="current-post-ancestor active current-post-parent dropdown menu-opinion"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="https://www.lafayettestudentnews.com/blog/category/op-ed/">Opinion <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="current-post-ancestor active current-post-parent menu-opinion"><a href="https://www.lafayettestudentnews.com/blog/category/op-ed/">Opinion</a></li>
	<li class="menu-editorials"><a href="https://www.lafayettestudentnews.com/blog/category/op-ed/letters-to-the-editor/">Editorials</a></li>
	<li class="menu-columns"><a href="https://www.lafayettestudentnews.com/blog/category/arts/columns/">Columns</a></li>
	<li class="menu-scoffayette"><a href="https://www.lafayettestudentnews.com/blog/category/arts/other-arts/scoffayette/">Scoffayette</a></li>
	<li class="menu-on-the-spot"><a href="https://www.lafayettestudentnews.com/blog/category/multimedia/on-the-spot/">On the Spot</a></li>
	<li class="menu-top-ten"><a href="https://www.lafayettestudentnews.com/blog/category/op-ed/other-opinion/top-ten/">Top Ten</a></li>
</ul>
</li>
<li class="menu-advertise"><a href="https://www.lafayettestudentnews.com/advertise-with-us/">Advertise</a></li>
<li class="menu-subscribe"><a href="https://www.lafayettestudentnews.com/subscribe/">Subscribe</a></li>
<li class="menu-submissions"><a href="https://www.lafayettestudentnews.com/article-suggestions/">Submissions</a></li>
<li class="menu-archives"><a target="_blank" href="http://digital.lafayette.edu/collections/newspaper">Archives</a></li>
</ul>						<div class="hidden-xs hidden-sm">		<ul class="nav navbar-nav navbar-right">
									<li class="twitter">
				<a href="http://www.twitter.com/TheLafayette"><i class="fa fa-twitter"></i></a>
			</li>
						<li class="facebook">
				<a href="http://www.facebook.com/TheLafayette"><i class="fa fa-facebook"></i></a>
			</li>
									<li class="rss"><a href="https://www.lafayettestudentnews.com/feed/"><i class="fa fa-rss"></i></a></li>			<li class="user"><a href="https://www.lafayettestudentnews.com/wp-login.php"><i class="fa fa-user"></i></a></li>		</ul>
	</div>
					</div>
				</nav>

								<div class="under-navigation hidden-xs hidden-sm">
					<div class="row">
						<div class="col-md-9 hidden-xs hidden-sm">		<aside id="news-ticker-2" class="widget dw_focus_widget_news_ticker">		<h2 class="widget-title">Recent News</h2>		<div class="news-ticker-wrap headlines" data-interval="4000">
			<ul>
							<li>
					<a href="https://www.lafayettestudentnews.com/blog/2017/02/24/going-south-for-the-winter-baseball-opens-up-season-at-the-irish-alamo-invitational-in-texas/">Going south for the winter: Baseball opens up season at the Irish Alamo Invitational in Texas</a>
									<span class="post-date">February 24, 2017</span>
								</li>
							<li>
					<a href="https://www.lafayettestudentnews.com/blog/2017/02/24/new-easton-nyc-bus-line-brings-low-ticket-prices/">New Easton-NYC bus line brings low ticket prices</a>
									<span class="post-date">February 24, 2017</span>
								</li>
							<li>
					<a href="https://www.lafayettestudentnews.com/blog/2017/02/24/survey-students-find-lack-of-student-government-impact/">Survey: Students find lack of student government impact</a>
									<span class="post-date">February 24, 2017</span>
								</li>
							<li>
					<a href="https://www.lafayettestudentnews.com/blog/2017/02/24/reaching-new-heights-the-ski-club-qualifies-for-nationals-for-the-second-straight-year/">Reaching new heights: The ski club qualifies for nationals for the second straight year</a>
									<span class="post-date">February 24, 2017</span>
								</li>
							<li>
					<a href="https://www.lafayettestudentnews.com/blog/2017/02/24/social-justice-keynote-explores-media-oppression-stereotyping/">Social Justice keynote explores media oppression, stereotyping</a>
									<span class="post-date">February 24, 2017</span>
								</li>
						</ul>
		</div>
		</aside>		</div>
						<div class="col-md-3"><form method="get" id="searchform" action="https://www.lafayettestudentnews.com/">
	<input type="text" name="s" id="s" class="form-control" value="" placeholder="Search">
	<input type="submit" class="search-submit">
</form>
</div>
					</div>
				</div>
							</div>
		</div>
	</header>

	<div id="content" class="site-content">

<div class="container">
	<div class="content-inner">
		<div class="row">
			<div class="col-lg-9">
				<div id="primary" class="content-area">
					<main id="main" class="site-main" role="main">
																	
	<article id="post-18159" class="post-18159 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-op-ed">
		<header class="entry-header">
			<h1 class="entry-title">Trump&#8217;s Incompetence Continues: Column</h1>
			<div class="entry-meta">
				<span class="cat-links"><i class="fa fa-folder"></i> <a href="https://www.lafayettestudentnews.com/blog/category/news/" rel="category tag">News</a>, <a href="https://www.lafayettestudentnews.com/blog/category/op-ed/" rel="category tag">Opinion</a></span><span class="posted-on"><i class="fa fa-clock-o"></i> <a href="https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/" rel="bookmark"><span class="entry-date published">February 17, 2017</span><span class="updated sr-only">February 17, 2017</span></a></span><span class="byline"> <i class="fa fa-user"></i> <a href="https://www.lafayettestudentnews.com/blog/author/mitterhm/" title="Posts by Matthew Mitterhoff" class="author url fn" rel="author">Matthew Mitterhoff</a></span>			</div>
		</header>

				<div class="entry-thumbnail">
		<img width="275" height="183" src="https://www.lafayettestudentnews.com/wp-content/uploads/2016/11/donald-trump.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="President Donald Trump giving a speech." srcset="https://www.lafayettestudentnews.com/wp-content/uploads/2016/11/donald-trump.jpg 275w, https://www.lafayettestudentnews.com/wp-content/uploads/2016/11/donald-trump-230x153.jpg 230w" sizes="(max-width: 275px) 100vw, 275px" />President Donald Trump giving a speech.		</div>
	
	<div class="row">
		<div class="entry-content col-md-9 col-md-push-3">
			<!-- AddThis Sharing Buttons above -->
                <div class="addthis_toolbox addthis_default_style addthis_32x32_style" addthis:url='https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/' addthis:title='Trump&#8217;s Incompetence Continues: Column' >
                    <a class="addthis_button_preferred_1"></a>
                    <a class="addthis_button_preferred_2"></a>
                    <a class="addthis_button_preferred_3"></a>
                    <a class="addthis_button_preferred_4"></a>
                    <a class="addthis_button_compact"></a>
                    <a class="addthis_counter addthis_bubble_style"></a>
                </div><p>A day wouldn’t feel normal if there wasn’t a news story corroborating what a majority of voters already knew: President Donald Trump and his administration are unfit to govern.</p>
<p>It started this week with former National Security Advisor Michael Flynn, who, after a weekend of revelations that he had misled Vice President Mike Pence with lies he had not <a href="https://www.nytimes.com/aponline/2017/02/13/us/politics/ap-us-trump.html">discussed sanctions</a> with Russia before Trump took office, resigned late Monday night.</p>
<p>With the reports of Flynn’s falsehoods came conflicting reports from the White House about the knowledge of them. Trump said last Friday that he <a href="https://www.theguardian.com/us-news/2017/feb/14/michael-flynn-resignation-explainer-white-house-counsel">did not know</a> that Flynn had been in contact with the Russians before January. Yet on Tuesday, White House Press Secretary Sean Spicer said that Trump had been told about Flynn only <a href="http://www.nbcnews.com/politics/donald-trump/mike-pence-told-about-flynn-warning-11-days-after-trump-n720836">six days after</a> his inauguration – two weeks before Pence found out.</p>
<p>Then, on Wednesday, Trump’s nominee for Secretary of Labor Andrew Puzder <a href="https://www.nytimes.com/2017/02/15/us/politics/andrew-puzder-withdrew-labor-secretary.html">withdrew his name</a> from nomination following <a href="https://www.nytimes.com/2017/02/14/us/politics/andrew-puzder-labor-secretary.html">reports</a> that he had abused his ex-wife and had employed an undocumented housekeeper that he had failed to pay taxes on.</p>
<p>Other nominees have faced and are facing tough nomination processes. There was Vincent Viola, who was Trump’s nominee for Army Secretary, who also withdrew his name from consideration due to his inability to sever ties with his businesses. There was Betsy DeVos, who had to be approved by a vice presidential tie-breaker. And there’s Scott Pruitt, Trump’s nominee for the Environmental Protection Agency, who faces <a href="https://www.washingtonpost.com/news/energy-environment/wp/2017/02/15/susan-collins-says-she-will-vote-against-trumps-epa-nominee/?utm_term=.9d6a6c3513b5">opposition</a> from environmental groups and from Susan Collins, a Republican senator from Maine. (Collins was also one of the two Republicans who voted against DeVos’s confirmation).</p>
<p>Constant problems with nominees and the fact that Trump’s cabinet is taking longer to fill than in recent history shows that Trump can’t pick leaders worth a damn. His nominees are either inexperienced, have huge conflict of interests, or, in the case of Department of Energy Secretary Rick Perry, have <a href="https://www.youtube.com/watch?v=EwG67GpJ63E">forgotten</a> the names of their departments in the past and <a href="http://thehill.com/policy/energy-environment/315005-rick-perry-misunderstood-energy-secretary-job-report">don’t even understand</a> the job they’re doing.</p>
<p>As for contact with Russia, it’s becoming more and more believable that Trump is colluding with the government. On Tuesday <a href="https://www.nytimes.com/2017/02/14/us/politics/russia-intelligence-communications-trump.html">news broke</a> that a number of Trump campaign staffers and Trump associates had contact with Russia in the year preceding the election. If Trump says he has no knowledge of that communication, he’s either lying or has no control over his staffers. I’m unsure which is worse.</p>
<p>Here’s the thing about scandals. They’re like a line of dominoes. Once one starts falling, so do the rest, until the ivory-colored slabs are all face down and lying on top of each other.</p>
<p>Let’s just hope they don’t knock into anything else on the way down.</p>
<!-- AddThis Sharing Buttons below -->
                <div class="addthis_toolbox addthis_default_style addthis_" addthis:url='https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/' addthis:title='Trump&#8217;s Incompetence Continues: Column' >
                    <a class="addthis_button_preferred_1"></a>
                    <a class="addthis_button_preferred_2"></a>
                    <a class="addthis_button_preferred_3"></a>
                    <a class="addthis_button_preferred_4"></a>
                    <a class="addthis_button_compact"></a>
                    <a class="addthis_counter addthis_bubble_style"></a>
                </div>						</div>
			<div class="entry-sidebar col-md-3 col-md-pull-9">
						<div class="entry-sharing">
			<h3>Sharing</h3>
							<ul class="list-group">
					<li class="list-group-item"><a href="mailto:?Subject=Trump&#8217;s Incompetence Continues: Column&amp;body=https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/"><i class="fa fa-envelope"></i> Email this article</a></li>
					<li class="list-group-item"><a onclick="window.print();"><i class="fa fa-print"></i> Print this article</a></li>
				</ul>
						</div>
						</div>
		</div>


	</article>
																					<div class="author-info">
										<div class="author-avatar">
											<img alt='' src='https://secure.gravatar.com/avatar/990b590e956b1e4bbdd42b110a4f58c1?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/990b590e956b1e4bbdd42b110a4f58c1?s=144&amp;d=mm&amp;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' />										</div>
										<div class="author-description">
											<h4>About Matthew Mitterhoff</h4>
																						<a class="author-link" href="https://www.lafayettestudentnews.com/blog/author/mitterhm/" rel="author">
												View all posts by Matthew Mitterhoff <span class="meta-nav">&rarr;</span>											</a>
										</div>
									</div>
															
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.lafayettestudentnews.com/blog/2017/02/17/good-as-gone-doesnt-live-up-to-gone-girl/" rel="prev">&#8216;Good as Gone&#8217; doesn&#8217;t live up to &#8216;Gone Girl&#8217;</a></div><div class="nav-next"><a href="https://www.lafayettestudentnews.com/blog/2017/02/17/housing-exemption-to-end-three-student-limit-to-be-enforced/" rel="next">Housing exemption to end: Three student limit to be enforced</a></div></div>
	</nav>																		<!-- Related Posts  -->
							
						
<section id="comments" class="comments">
			<h3 class="comments-title">
			1 comments		</h3>

		
		<div class="comment-list">
					<div id="comment-71995" class="comment even thread-even depth-1">
			<article id="div-comment-71995" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/32f7f817bbd27291dfd73344438d5cf1?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/32f7f817bbd27291dfd73344438d5cf1?s=64&amp;d=mm&amp;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />						<b class="fn">Mike1776</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/#comment-71995">
							<time datetime="2017-02-19T23:29:04+00:00">
								February 19, 2017 at 11:29 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Matthew Mitterhoff is absolutely right.  Trump, the New York real-estate fraudster, is a disaster in the White House: ignorant, reckless and incompetent.  He will do terrible harm to America until he is removed.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.lafayettestudentnews.com/blog/2017/02/17/trumps-incompetence-continues/?replytocom=71995#respond' onclick='return addComment.moveForm( "div-comment-71995", "71995", "respond", "18159" )' aria-label='Reply to Mike1776'>Reply</a></div>			</article><!-- .comment-body -->
</div><!-- #comment-## -->
		</div>

		
	
	
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/2017/02/17/trumps-incompetence-continues/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="https://www.lafayettestudentnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<p class="comment-form"><label for="comment">Comment</label><textarea id="comment" name="comment" class="form-control" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" class="form-control" aria-required=true /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" class="form-control" aria-required=true /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" class="form-control" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-default" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='18159' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="99795f127c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="180"/></p>				</form>
					</div><!-- #respond -->
		
</section>
										</main>
				</div>
			</div>
			<div class="col-lg-3">
				
<div id="secondary" class="widget-area" role="complementary">
	<aside id="rss-6" class="widget widget_rss"><h2 class="widget-title"><a class="rsswidget" href="http://chronicle.com/section/News/6/rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.lafayettestudentnews.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://www.chronicle.com/section/News/6/">Chronicle of Higher Education</a></h2><ul><li><a class='rsswidget' href='http://www.chronicle.com/article/Colleges-Try-to-Ease-Immigrant/239317'>Colleges Try to Ease Immigrant Students&#039; Stress as Government Steps Up Deportations</a></li><li><a class='rsswidget' href='http://www.chronicle.com/article/The-Alumni-Colleges-Aren-t/239316'>The Alumni Colleges Aren’t Bragging About: Members of Trump’s Inner Circle</a></li><li><a class='rsswidget' href='http://www.chronicle.com/article/A-Sociologist-Looks-at-the/239314'>A Sociologist Looks at the Failure of the For-Profits and the Rise of Trump</a></li><li><a class='rsswidget' href='http://www.chronicle.com/blogs/ticker/betsy-devos-criticizes-professors-in-remarks-to-conservative-conference/117049'>Betsy DeVos Criticizes Professors in Remarks to Conservative Conference</a></li><li><a class='rsswidget' href='http://www.chronicle.com/article/Campus-Conservatives-Get-a/239309'>Campus Conservatives Get a Lesson in Activism: When Professors Start Ranting, Start Filming</a></li></ul></aside><aside id="archives-3" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<ul>
			<li><a href='https://www.lafayettestudentnews.com/blog/2017/02/'>February 2017</a>&nbsp;(101)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2017/01/'>January 2017</a>&nbsp;(26)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/12/'>December 2016</a>&nbsp;(43)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/11/'>November 2016</a>&nbsp;(70)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/10/'>October 2016</a>&nbsp;(61)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/09/'>September 2016</a>&nbsp;(96)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/08/'>August 2016</a>&nbsp;(3)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/05/'>May 2016</a>&nbsp;(16)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/04/'>April 2016</a>&nbsp;(94)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/03/'>March 2016</a>&nbsp;(51)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/02/'>February 2016</a>&nbsp;(77)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2016/01/'>January 2016</a>&nbsp;(19)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/12/'>December 2015</a>&nbsp;(43)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/11/'>November 2015</a>&nbsp;(47)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/10/'>October 2015</a>&nbsp;(83)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/09/'>September 2015</a>&nbsp;(82)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/07/'>July 2015</a>&nbsp;(1)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/05/'>May 2015</a>&nbsp;(43)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/04/'>April 2015</a>&nbsp;(80)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/03/'>March 2015</a>&nbsp;(65)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/02/'>February 2015</a>&nbsp;(84)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2015/01/'>January 2015</a>&nbsp;(18)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/12/'>December 2014</a>&nbsp;(21)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/11/'>November 2014</a>&nbsp;(56)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/10/'>October 2014</a>&nbsp;(87)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/09/'>September 2014</a>&nbsp;(86)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/08/'>August 2014</a>&nbsp;(23)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/05/'>May 2014</a>&nbsp;(43)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/04/'>April 2014</a>&nbsp;(92)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/03/'>March 2014</a>&nbsp;(68)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/02/'>February 2014</a>&nbsp;(92)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2014/01/'>January 2014</a>&nbsp;(22)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2013/12/'>December 2013</a>&nbsp;(21)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2013/11/'>November 2013</a>&nbsp;(89)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2013/10/'>October 2013</a>&nbsp;(69)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2013/09/'>September 2013</a>&nbsp;(104)</li>
	<li><a href='https://www.lafayettestudentnews.com/blog/2013/08/'>August 2013</a>&nbsp;(29)</li>
		</ul>
		</aside></div>
			</div>
		</div>
	</div>
</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="container">
			
<div id="footer-widgets" class="widget-area" role="complementary">
	<div class="row">
		<div class="col-lg-3 col-sm-2"><aside id="search-7" class="widget widget_search"><h2 class="widget-title">looking for something?</h2><form method="get" id="searchform" action="https://www.lafayettestudentnews.com/">
	<input type="text" name="s" id="s" class="form-control" value="" placeholder="Search">
	<input type="submit" class="search-submit">
</form>
</aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-10" class="widget widget_nav_menu"><h2 class="widget-title">Additional Information</h2><ul id="menu-contact" class="menu"><li class="menu-contact-us"><a href="https://www.lafayettestudentnews.com/contact-us/">Contact Us</a></li>
<li class="menu-subscribe-to-our-print-edition"><a href="https://www.lafayettestudentnews.com/subscribe/">Subscribe to our print edition!</a></li>
<li class="menu-advertise"><a href="https://www.lafayettestudentnews.com/advertise-with-us/">Advertise</a></li>
<li class="menu-meet-the-editorial-board"><a href="https://www.lafayettestudentnews.com/meet-the-staff/">Meet the Editorial Board</a></li>
<li class="menu-submissions"><a href="https://www.lafayettestudentnews.com/article-suggestions/">Submissions</a></li>
<li class="menu-comment-policy"><a href="https://www.lafayettestudentnews.com/comment-policy/">Comment Policy</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="calendar-3" class="widget widget_calendar"><h2 class="widget-title">jump to a specific date</h2><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>February 2017</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="https://www.lafayettestudentnews.com/blog/2017/01/">&laquo; Jan</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="3" class="pad">&nbsp;</td><td>1</td><td>2</td><td><a href="https://www.lafayettestudentnews.com/blog/2017/02/03/" aria-label="Posts published on February 3, 2017">3</a></td><td>4</td>
	</tr>
	<tr>
		<td>5</td><td>6</td><td>7</td><td>8</td><td>9</td><td><a href="https://www.lafayettestudentnews.com/blog/2017/02/10/" aria-label="Posts published on February 10, 2017">10</a></td><td><a href="https://www.lafayettestudentnews.com/blog/2017/02/11/" aria-label="Posts published on February 11, 2017">11</a></td>
	</tr>
	<tr>
		<td>12</td><td>13</td><td>14</td><td>15</td><td>16</td><td><a href="https://www.lafayettestudentnews.com/blog/2017/02/17/" aria-label="Posts published on February 17, 2017">17</a></td><td>18</td>
	</tr>
	<tr>
		<td>19</td><td>20</td><td>21</td><td>22</td><td>23</td><td id="today"><a href="https://www.lafayettestudentnews.com/blog/2017/02/24/" aria-label="Posts published on February 24, 2017">24</a></td><td>25</td>
	</tr>
	<tr>
		<td>26</td><td>27</td><td>28</td>
		<td class="pad" colspan="4">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside></div>
		<div class="col-lg-3 col-md-4 col-lg-offset-0 col-md-offset-2 col-sm-5 col-sm-offset-1"><aside id="meta-2" class="widget widget_meta"><h2 class="widget-title">Meta</h2>			<ul>
						<li><a href="https://www.lafayettestudentnews.com/wp-login.php">Log in</a></li>
			<li><a href="https://www.lafayettestudentnews.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://www.lafayettestudentnews.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside></div>
	</div>
</div>
			<div class="row">
				<div class="site-info col-md-6">
					Copyright &copy; 2017 by <a href="https://www.lafayettestudentnews.com">The Lafayette</a>.					Theme: <a href="http://www.designwall.com/wordpress/themes/dw-focus/" title="WordPress News Theme">DW Focus</a> by <a href="http://www.designwall.com/" rel="designer">DesignWall</a>.<br>
					<a href="http://wordpress.org/">Proudly powered by WordPress</a>
				</div>
												<div class="site-footer-logo col-md-6 text-right">
					<a href="https://www.lafayettestudentnews.com/" rel="home"><img src="//www.lafayettestudentnews.com/wp-content/uploads/2013/08/The-flag-for-website-e1471464996823.jpg" title="The Lafayette"></a>
				</div>
							</div>
		</div>
	</footer>
</div>
<script data-cfasync="false" type="text/javascript">
var addthis_config = {"data_track_clickback":false,"ui_atversion":300,"ignore_server_config":true};
var addthis_share = {};
</script>
                <!-- AddThis Settings Begin -->
                <script data-cfasync="false" type="text/javascript">
                    var addthis_product = "wpp-5.3.4";
                    var wp_product_version = "wpp-5.3.4";
                    var wp_blog_version = "4.6.1";
                    var addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"5.3.4","anonymous_profile_id":"wp-3942fbcd2424bb26d5284b83965fbaf6","plugin_mode":"WordPress","select_prefs":{"addthis_per_post_enabled":true,"addthis_above_enabled":true,"addthis_below_enabled":true,"addthis_sidebar_enabled":false,"addthis_mobile_toolbar_enabled":false,"addthis_above_showon_home":false,"addthis_below_showon_home":false,"addthis_above_showon_pages":false,"addthis_below_showon_pages":false,"addthis_above_showon_categories":false,"addthis_below_showon_categories":false,"addthis_above_showon_archives":false,"addthis_below_showon_archives":false,"addthis_above_showon_posts":true,"addthis_above_showon_excerpts":true,"addthis_below_showon_posts":true,"addthis_below_showon_excerpts":true,"addthis_sidebar_showon_home":true,"addthis_sidebar_showon_posts":true,"addthis_sidebar_showon_pages":true,"addthis_sidebar_showon_archives":true,"addthis_sidebar_showon_categories":true,"addthis_mobile_toolbar_showon_home":true,"addthis_mobile_toolbar_showon_posts":true,"addthis_mobile_toolbar_showon_pages":true,"addthis_mobile_toolbar_showon_archives":true,"addthis_mobile_toolbar_showon_categories":true,"sharing_enabled_on_post_via_metabox":true},"page_info":{"template":"posts","post_type":""}};
                    if (typeof(addthis_config) == "undefined") {
                        var addthis_config = {"data_track_clickback":false,"ui_atversion":300,"ignore_server_config":true};
                    }
                    if (typeof(addthis_share) == "undefined") {
                        var addthis_share = {};
                    }
                    if (typeof(addthis_layers) == "undefined") {
                        var addthis_layers = {};
                    }
                </script>
                <script
                    data-cfasync="false"
                    type="text/javascript"
                    src="//s7.addthis.com/js/300/addthis_widget.js#pubid=wp-3942fbcd2424bb26d5284b83965fbaf6 "
                    
                >
                </script>
                <script data-cfasync="false" type="text/javascript">
                    (function() {
                        var at_interval = setInterval(function () {
                            if(window.addthis) {
                                clearInterval(at_interval);
                                addthis.layers(addthis_layers);
                            }
                        },1000)
                    }());
                </script>
                <script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<link rel='stylesheet' id='addthis_output-css'  href='https://www.lafayettestudentnews.com/wp-content/plugins/addthis/css/output.css?ver=4.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-includes/js/comment-reply.min.js?ver=4.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/www.lafayettestudentnews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-content/themes/dw-focus/assets/js/dw-focus.min.js?ver=1.3.2'></script>
<script type='text/javascript' src='https://www.lafayettestudentnews.com/wp-includes/js/wp-embed.min.js?ver=4.6.1'></script>
<!--wp_footer--></body>
</html>
